pacman更新出错:eclipse and xulrunner are in conflict » 荒野无灯weblog

Keep It Simple, Stupid.

荒野无灯weblog

pacman更新出错:eclipse and xulrunner are in conflict

“eclipse and xulrunner are in conflict”?

此问题暂无解决办法。xulrunner(Mozilla Runtime Environment) 卸载了不太方便。。。我把 eclipse 包卸载了。。。


looking for inter-conflicts…
:: xf86-video-savage and savage-dri are in conflict. Remove savage-dri? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: mach64-dri: requires libgl=7.11.2
:: mga-dri: requires libgl=7.11.2
:: r128-dri: requires libgl=7.11.2
:: sis-dri: requires libgl=7.11.2
:: tdfx-dri: requires libgl=7.11.2

https://bbs.archlinux.org/viewtopic.php?pid=1024518#p1024518

sudo pacman -Rdd libgl

[admin@huangye ~]$ sudo pacman -Rdd libgl

Targets (1): libgl-7.11.2-1

Total Removed Size:     16.43 MiB

Do you want to remove these packages? [Y/n] y
(1/1) removing libgl                               [######################] 100%

yes a modified libGL is provided by catalyst driver (same happens with nvidia proprietary drivers FYI)

一些配置的改变,这里先记录下,有时间再diff下。

( 4/354) upgrading acpid [######################] 100%
warning: /etc/acpi/handler.sh installed as /etc/acpi/handler.sh.pacnew
( 28/354) upgrading udev [######################] 100%
udev changes:
* if your kernel does not provide /dev/loop-control, you need to manually
load the ‘loop’ module before using losetup

[admin@huangye etc]$ ls *.pacnew
dnsmasq.conf.pacnew gshadow.pacnew ntp.conf.pacnew
fstab.pacnew hosts.pacnew rc.conf.pacnew
group.pacnew mkinitcpio.conf.pacnew shadow.pacnew

Tagged in : pacman

All Comments (0)
Gravatar image
No Comments