wordpress 3.1到3.1.1手动升级文件[下载] » 荒野无灯weblog

Keep It Simple, Stupid.

荒野无灯weblog

wordpress 3.1到3.1.1手动升级文件[下载]

要我把文件全部传一遍,真的不想。花了点时间做了个升级包,官方这次没有列出升级的文件名,我用beyondcompare做的。

│  readme.html
│  
├─wp-admin
│  │  media-upload.php
│  │  network.php
│  │  upgrade.php
│  │  
│  ├─includes
│  │      class-wp-ms-sites-list-table.php
│  │      class-wp-upgrader.php
│  │      dashboard.php
│  │      media.php
│  │      update-core.php
│  │      
│  ├─network
│  │      admin.php
│  │      settings.php
│  │      
│  └─user
│          admin.php
│          
├─wp-content
│  └─themes
│      └─twentyten
│          └─languages
│                  twentyten.pot
│                  
└─wp-includes
    │  admin-bar.php
    │  canonical.php
    │  class-pop3.php
    │  formatting.php
    │  functions.php
    │  link-template.php
    │  meta.php
    │  post.php
    │  query.php
    │  rewrite.php
    │  script-loader.php
    │  taxonomy.php
    │  version.php
    │  wp-db.php
    │  
    ├─css
    │      admin-bar.css
    │      admin-bar.dev.css
    │      
    └─js
        └─tinymce
                tiny_mce.js
                wp-tinymce.js.gz

直接覆盖这些文件(如果是FlashFXP,上传时选择“全部覆盖”。注意上传模式尽量选择二进制模式。),然后访问:

你的博客URL/wp-admin/upgrade.php

升级下数据库,OK啦。 :cool:

升级包这里给出来,需要的拿去吧,谁叫我是雷锋同志呢?
此文件对于中英文版的程序都是一样:

www.ihaclog.com-WordPress_3.1upgradeto3.1.1.zip (428.4 KB)

如果是用的官方中文版的,则还要把以下文件覆盖一下:

wp-content
├─languages
│      continents-cities-zh_CN.mo
│      continents-cities-zh_CN.po
│      ms-zh_CN.mo
│      ms-zh_CN.po
│      zh_CN.mo
│      zh_CN.po
│      
└─themes
    └─twentyten
        └─languages
                twentyten.pot

lang-wordpress-3.1.1-zh_CN.zip (333.0 KB)

以下内容引用自http://cn.wordpress.org/2011/04/05/wordpress-3-1-1/:

WordPress 3.1.1 中文版本现已发布。此版本是修订版本,修复了 3.1 中包含安全问题在内的近 30 个问题。几个重要更新内容:

加强媒体文件上传的安全性
性能改进
增加对 IIS6 的支持
修正分类和 PATHINFO(/index.php/)的固定链接问题
修正了在某些极端情况下,数据库查询和分类法相关内容可能导致插件不兼容的问题

3.1.1 版本包含了我们的安全团队成员、WordPress 核心开发者 Jon CavePeter Westwood 发现的 3 个安全问题。修复的内容分别是:修正媒体文件上传器包含的“跨站请求伪造”(CSRF)问题、修正在处理评论内容中极复杂链接时可能导致的 PHP 崩溃的问题,以及修补“跨网站指令码”(XSS)漏洞。

我们建议您尽快升级至 3.1.1 版本。下载 3.1.1 版本,或通过您站点管理区域的控制板 → 更新菜单升级。

更多信息,您可访问中文文档页面查看。

Tagged in : wordpress,wp,wp升级,手动升级

All Comments (0)
Gravatar image
No Comments